Cambiando el JDK para ejecutar IntelliJ IDEA

Otra vez un post para IDEA, uno de estos días, reporte un bug y al fijarme el build de mi instalación de IDEA (Menú “About IntelliJ IDEA”), veo que está ejecutandose con el JDK 1.5 y no con el 1.6 que tengo instalado (pero si estaba usando el JDK1.6 para compilar mis proyectos).

Como las configuraciónes están en el archivo info.plist dentro del paquete de IDEA, tuve que cambiar algunas cosas:

      <key>JVMVersion</key>

      <string>1.6*</string>

      <key>JVMArchs</key>

      <string>x86_64</string>

Creo que no se necesita explicación, es bastante obvio, ahora si estoy ejecutando IDEA con el ultimo JDK además en 64 bits (antes estaba como x86_32).

Anuncios